Limited power but no warnings?

wtf

Well-Known Member
First Name
Mark
Joined
Dec 24, 2018
Messages
56
Reaction score
75
Location
Australia
Car(s)
500hp 97 TT 6sp Aero, 800hp 98 GTX3584 6sp hardtop, 1000hp 92 R32GTR, 1300hp VR41 GT86, 600hp RB26 180SX, 1000hp R35GTR, 400hp SR20 AE86...
Hi guys,

My A90 supra is totally stock, and I have been surprised that few people seem to have mentioned any kind of power limiting on their car especially for those who have upgraded turbos, downpipes, tunes and so forth.

I came across this issue first on the circuit, after 2 laps, it seemed the car went into a limited power almost limp mode at high speed, basically on the straights at top of 4th.

Essentially it felt like I was only pressing 50% throttle which was frustrating as it was happening just before crossing the start/finish line and killing my lap times.

There are no warnings, no CEL, nothing obvious that would suggest there was a problem.

If I bring up the "sports displays" I noticed the power was maxing out at around 145kw instead of the usual 245kw on the screen.

If I backed off for 10 seconds the car went back to normal, which made me think maybe it was intake temp related.

Ideally I would have liked to be logging oil and intake temps via obd but I was already busy with getting myself sorted for the track sessions that I didn't have time to do debugging.

I later turned the air con off and for the rest of the day, I didn't experience a power limit.

Now here's were it's strange, last night in cool night air, on the highway I experienced the same issue for the first time *on the street*, after overtaking a few cars to get into the off ramp.. same symptoms, limited power, no warning, but power displays only going up half way.

Being that it was a chilly night I didn't expect anything of the sort.

I know another Australian supra had the same issue at roll racing, but I am wondering if anyone else has narrowed down the issue and has an answer/solution?

I mean Australia is typically warmer than rest of world, but it seems pretty stupid I get no warning or CEL to indicate there's an issue..

Any help or experience welcomed :)

Mark


82442535_10218932082190991_2528645395471400960_o.jpg
IMG_20200325_014121_412.jpg





Advertisement

 

a90moe

Well-Known Member
Joined
Nov 9, 2019
Messages
814
Reaction score
773
Location
Earth
Car(s)
MKV Supra
Did you check for any codes?

Also, if fuel level was low and on the track it could be fuel starvation
 

fireball

Active Member
Joined
Jul 21, 2019
Messages
37
Reaction score
15
Location
Aust
Car(s)
a90
What QR event was this ? I've been meaning to go out with the supra but have just been just too busy :(. at a guess it could be fuel because jackie ding did mention having to run a full tank to avoid cut out in 1 video. the other like you mentioned could be overheating
 
OP
wtf

wtf

Well-Known Member
First Name
Mark
Joined
Dec 24, 2018
Messages
56
Reaction score
75
Location
Australia
Car(s)
500hp 97 TT 6sp Aero, 800hp 98 GTX3584 6sp hardtop, 1000hp 92 R32GTR, 1300hp VR41 GT86, 600hp RB26 180SX, 1000hp R35GTR, 400hp SR20 AE86...
  • Thread starter
  • Thread Starter
  • #4
Did you check for any codes?

Also, if fuel level was low and on the track it could be fuel starvation
Unfortunately I had power cycled before I got a chance to check, but there was no fuel starvation issues. Last night it did it on the highway with a full tank of fuel, in a straight line..

If starvation you'd expect it to happen on heavy cornering, but every time it's happened was half way down a 1km straight, which is about as far from a corner as you'd get.

Confusing me greatly, and strange more people aren't experiencing it.
 
OP
wtf

wtf

Well-Known Member
First Name
Mark
Joined
Dec 24, 2018
Messages
56
Reaction score
75
Location
Australia
Car(s)
500hp 97 TT 6sp Aero, 800hp 98 GTX3584 6sp hardtop, 1000hp 92 R32GTR, 1300hp VR41 GT86, 600hp RB26 180SX, 1000hp R35GTR, 400hp SR20 AE86...
  • Thread starter
  • Thread Starter
  • #5
What QR event was this ? I've been meaning to go out with the supra but have just been just too busy :(. at a guess it could be fuel because jackie ding did mention having to run a full tank to avoid cut out in 1 video. the other like you mentioned could be overheating
First event was King of QR, came third in "Track tuned forced induction class" completely stock.

Second event was with the new wheels and tyres, at a regular sprint day.

Does very well for a stock car, but it's atrocious ESC/TRC tries to put you into the wall even when it's disabled..

Not impressed with some of the track handling at or on the limit in the car.
 
OP
wtf

wtf

Well-Known Member
First Name
Mark
Joined
Dec 24, 2018
Messages
56
Reaction score
75
Location
Australia
Car(s)
500hp 97 TT 6sp Aero, 800hp 98 GTX3584 6sp hardtop, 1000hp 92 R32GTR, 1300hp VR41 GT86, 600hp RB26 180SX, 1000hp R35GTR, 400hp SR20 AE86...
  • Thread starter
  • Thread Starter
  • #8
Never heard of or felt any power loss other than when traction control is triggered.
Yeah at those speeds traction control not an issue, this is at 140+kph then just stops accelerating normally..

i'll remember to take it easy if and when i go out to QR. Did you do a check wheel alignment. early on there were some supra's misaligned from factory as well. see this https://www.thedrive.com/news/31031/is-the-2020-toyota-supra-broken-straight-from-the-factory

First track day I didnt do an alignment, but there was very little alignment adjustment on the car anyway, the front gives you a tiny bit of caster/toe but that's all.

My alignment from stock was pretty much spot on.
 
OP
wtf

wtf

Well-Known Member
First Name
Mark
Joined
Dec 24, 2018
Messages
56
Reaction score
75
Location
Australia
Car(s)
500hp 97 TT 6sp Aero, 800hp 98 GTX3584 6sp hardtop, 1000hp 92 R32GTR, 1300hp VR41 GT86, 600hp RB26 180SX, 1000hp R35GTR, 400hp SR20 AE86...
  • Thread starter
  • Thread Starter
  • #10
OP
wtf

wtf

Well-Known Member
First Name
Mark
Joined
Dec 24, 2018
Messages
56
Reaction score
75
Location
Australia
Car(s)
500hp 97 TT 6sp Aero, 800hp 98 GTX3584 6sp hardtop, 1000hp 92 R32GTR, 1300hp VR41 GT86, 600hp RB26 180SX, 1000hp R35GTR, 400hp SR20 AE86...
  • Thread starter
  • Thread Starter
  • #12
Try to replicate and then scan for codes :)
Had expected it was only a track day thing, so didnt really think to log street driving..

I might start logging next time i take the car for a drive... But it has never done it in 3000km driving, except on the track, so might be needing a good flogging for it to happen aaha
 

s219

Well-Known Member
First Name
Doc
Joined
Jun 22, 2019
Messages
502
Reaction score
577
Location
Virginia USA
Car(s)
BMW X3 M40i, BMW M2 Comp, Honda S2000
Jackie Ding experienced this I believe. There can be a range of reasons. I think that even things that affect tire pressure, TPMS, tire size, ABS sensor, etc can trigger various limp modes. Transmission or differential temperature may also be a trigger.
 

Torquem

Well-Known Member
Joined
Jan 4, 2020
Messages
134
Reaction score
152
Location
Raleigh. NC
Car(s)
2020 Supra Premium
I was reading another forum member that was complaining of cut power after flogging on his car. Street driving. Said after a few minutes of normal driving it would go away. Would make me think it is temp related.
 

Advertisement





 


Advertisement
Top