What o2 extender works?

Discussion in 'B58 6-Cyl Engine, Exhaust, Drivetrain, Bolt-Ons' started by Toyotawild, Sep 22, 2019.

  1. Fast_Freddie

    Fast_Freddie Active Member

    First Name:
    Freddie
    Car(s):
    2020 Turbulence Gray Premium, 2010 CTS-V, 2005 Evo VIII
    Joined:
    Sep 7, 2019
    Location:
    Lexington Park, Maryland
    Posts:
    36
    Liked:
    21
    Garage Profiles:
    3
    I just bit the bullet today and ordered a unit from Fabspeed... called and got 15% off for veteran discount and free shipping... they are on sale right now as well for 10% off and free shipping to promote their open house this weekend. They are in PA so it will be delivered tomorrow to MD. Hopefully it gets rid of this pesky P0141 heater malfunction code...
     
    MA617M likes this.
  2. OP
    OP
    Toyotawild

    Toyotawild Well-Known Member

    First Name:
    Zach
    Car(s):
    07 Toyota Tundra supercharged, 03 Acura cls-6
    Joined:
    Apr 27, 2019
    Location:
    Richland wa
    Posts:
    352
    Liked:
    242
    Did you get the 45 or the 90 degree?
     
    084runnerltd likes this.
  3. MA617M

    MA617M Well-Known Member

    Car(s):
    lots
    Joined:
    Aug 27, 2017
    Location:
    Australia
    Posts:
    1,800
    Liked:
    4,328
    Occupation:
    Engineer
    Keen to hear results. I'm going to make an RHD 4-4.5" dump for the car and don't want to have to tune it yet.
     
  4. imoj1

    imoj1 Well-Known Member

    First Name:
    Omran
    Car(s):
    95' Supra, '15 Maserati, '98 Skyline, '15 Mustang, M5
    Joined:
    Jan 20, 2019
    Location:
    dubai
    Posts:
    108
    Liked:
    129
    let us know how this goes

    i just purchased the big daddy mini cat, will wait till i get it
     
    SUPRATOY likes this.
  5. Fast_Freddie

    Fast_Freddie Active Member

    First Name:
    Freddie
    Car(s):
    2020 Turbulence Gray Premium, 2010 CTS-V, 2005 Evo VIII
    Joined:
    Sep 7, 2019
    Location:
    Lexington Park, Maryland
    Posts:
    36
    Liked:
    21
    Garage Profiles:
    3
    Fabspeed is a quaility product, but it still throws a P0141 O2 heater code since it does not heat up the sensor fast enough... I am trying one other one I got in from ebay for $15 until I say screw it and chalk it up as an L and get a tune :)

    It is weird though, the test the sensor is failing for, almost makes me think it is a bad sensor...
     
    RRKnight and MA617M like this.
  6. OP
    OP
    Toyotawild

    Toyotawild Well-Known Member

    First Name:
    Zach
    Car(s):
    07 Toyota Tundra supercharged, 03 Acura cls-6
    Joined:
    Apr 27, 2019
    Location:
    Richland wa
    Posts:
    352
    Liked:
    242
    Dang it. Hmm
     
  7. AHP

    AHP Well-Known Member

    Car(s):
    '93 Supra TT Hardtop, '09 Corvette ZR1, '07 Corvette, '13 G37x, '10 Escalade ESV
    Joined:
    Nov 28, 2018
    Location:
    CLT, NC
    Posts:
    174
    Liked:
    269
    Garage Profiles:
    1


    P0141 generally indicates the sensor itself is bad; specifically the heater circuit within the sensor and/or associated wiring. If the mini cat wasn't working well enough I would expect a catalyst inefficiency code like a P0420. I'd check continuity and replace the sensor before anything else.
     
  8. Fast_Freddie

    Fast_Freddie Active Member

    First Name:
    Freddie
    Car(s):
    2020 Turbulence Gray Premium, 2010 CTS-V, 2005 Evo VIII
    Joined:
    Sep 7, 2019
    Location:
    Lexington Park, Maryland
    Posts:
    36
    Liked:
    21
    Garage Profiles:
    3
    I understand that a P0141 would seem like a failed sensor, which I mentioned earlier as I thought the same... and I would agree with you if this sensor didn't only have 1000 miles on it, didn't read open between the heater resistor (read 6 ohms) and that the ohmic value dropped to within tolerance today after I put the ebay spacer in today, which moved the sensor closer to the exhaust.
     
  9. 084runnerltd

    084runnerltd Well-Known Member

    First Name:
    Jake
    Car(s):
    08 4Runner / 99’ Lexus LX470 / Deposit 2020 Supra
    Joined:
    Feb 15, 2019
    Location:
    ND
    Posts:
    391
    Liked:
    361
    Occupation:
    Financial Advisor
    Garage Profiles:
    3
    I so much want a downpipe, but I so much don’t want a cel light....
     
    MA617M and kabnine like this.
  10. SUPRATOY

    SUPRATOY Active Member

    First Name:
    Luis
    Car(s):
    2020 SUPRA
    Joined:
    Aug 2, 2019
    Location:
    Florida
    Posts:
    40
    Liked:
    21
    I have been getting the P0136 and P0141 codes after the Titan downpipe and extender install. the CEL comes on for a day or so and then goes off to come back on again. I have been debating between getting the flash done or get a high flow cat downpipe, meanwhile I'm waiting to see if a solution comes from this thread!
     
  11. larrymz3

    larrymz3 Well-Known Member

    Car(s):
    2020 Supra
    Joined:
    Sep 8, 2019
    Location:
    Arkansas
    Posts:
    170
    Liked:
    74
    Even with a high flow cat there is a significant chance that you will still get a CEL.

    I'm getting mine installed tomorrow. I got the Titan dp and the Fabspeed extender. if the extender doesn't work I'm going to return it as there are MUCH cheaper options on the market as far as mini cat/spacer.
     
    084runnerltd likes this.
  12. 084runnerltd

    084runnerltd Well-Known Member

    First Name:
    Jake
    Car(s):
    08 4Runner / 99’ Lexus LX470 / Deposit 2020 Supra
    Joined:
    Feb 15, 2019
    Location:
    ND
    Posts:
    391
    Liked:
    361
    Occupation:
    Financial Advisor
    Garage Profiles:
    3
    keep us posted please.
     
  13. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    264
    Liked:
    173
    I just installed the euromotive performance dp with their O2 space mini cat and no CEL. The car feels and sound amazing!

    20191005_165058.jpg
     
    Haros, Mk5nut, MA617M and 1 other person like this.
  14. RenierR10

    RenierR10 Active Member

    First Name:
    Alexis
    Car(s):
    MKV Supra
    Joined:
    Aug 28, 2019
    Location:
    New York
    Posts:
    42
    Liked:
    22
    Garage Profiles:
    1
    Installed Titan downpipe with fabspeed extender yesterday. Just got a CEL light today.
     
  15. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    264
    Liked:
    173
    I got the CEL today too but is it related to downpipe?

    Screenshot_20191009-065827_JB4 Mobile.jpg
     

Share This Page

Loading...