What o2 extender works?

Discussion in 'B58 6-Cyl Engine, Exhaust, Drivetrain, Bolt-Ons' started by Toyotawild, Sep 22, 2019.

  1. OP
    OP
    Toyotawild

    Toyotawild Well-Known Member

    First Name:
    Zach
    Car(s):
    07 Toyota Tundra supercharged, 03 Acura cls-6
    Joined:
    Apr 27, 2019
    Location:
    Richland wa
    Posts:
    378
    Liked:
    254
    Doesn't look like it
     
    RRKnight likes this.
  2. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    266
    Liked:
    180
    I will clear the codes today and monitor it. I have the feeling it's the JB4 pushing the fuel and idles up that's causing this.
     
  3. larrymz3

    larrymz3 Well-Known Member

    Car(s):
    2020 Supra
    Joined:
    Sep 8, 2019
    Location:
    Arkansas
    Posts:
    283
    Liked:
    117
    What map are you running? I'm on map 3 with titan downpipe/fabspeed cat and no codes.
     
  4. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    266
    Liked:
    180
    Running map 3 with 94 octane and downpipe.
     
  5. larrymz3

    larrymz3 Well-Known Member

    Car(s):
    2020 Supra
    Joined:
    Sep 8, 2019
    Location:
    Arkansas
    Posts:
    283
    Liked:
    117
    Yeah, sounds like something else. I'm on 93 octane with DP and no codes. Any other mods or changes to car?
     
  6. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    266
    Liked:
    180
    Only k&n drop in filter with gray foam removed.
     
  7. larrymz3

    larrymz3 Well-Known Member

    Car(s):
    2020 Supra
    Joined:
    Sep 8, 2019
    Location:
    Arkansas
    Posts:
    283
    Liked:
    117
    Ok, similiar here - I'm running the AFE dry filter with carbon foam removed.

    You didn't happen to oil or clean the K&N did you? I've heard TONS of stories of K&N's dumping oil on the MAF and causing issues.
     
  8. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    266
    Liked:
    180
    Nope. I just drop the filter in. There wasn't enough oil on it to drip anything.
     
  9. RenierR10

    RenierR10 Well-Known Member

    First Name:
    Alexis
    Car(s):
    MKV Supra
    Joined:
    Aug 28, 2019
    Location:
    New York
    Posts:
    64
    Liked:
    31
    Garage Profiles:
    1
    You have the Fabspeed extender and no CEL? I got downpipe installed yesterday and now have a CEL. Is it possible to switch out an extender without having to dropping take out downpipe? From the bottom perhaps?
     
  10. RenierR10

    RenierR10 Well-Known Member

    First Name:
    Alexis
    Car(s):
    MKV Supra
    Joined:
    Aug 28, 2019
    Location:
    New York
    Posts:
    64
    Liked:
    31
    Garage Profiles:
    1
    Shouldn’t you run map 4 with downpipe? I’ll try going back to map 3 sea what happens.
     
  11. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    266
    Liked:
    180
    I upgraded the JB4 firmware to V14. It says map 4 is for BEF setup.
     
  12. 084runnerltd

    084runnerltd Well-Known Member

    First Name:
    Jake
    Car(s):
    08 4Runner / 99’ Lexus LX470 / Deposit 2020 Supra
    Joined:
    Feb 15, 2019
    Location:
    ND
    Posts:
    433
    Liked:
    413
    Occupation:
    Financial Advisor
    Garage Profiles:
    3
    #42 Oct 9, 2019
    Last edited: Oct 9, 2019
    I have never had patience....

    Got home from work, my “race ramps” won’t arrive til tomorrow, I thought, what the hell, let’s give it a go and try the install with my 6” plastic ramps...

    2.5 hours later, the DP is in....I know, I know, I am a little slow. However, doing the downpipe with your nose rubbing on the underbody of the car sucks. I had to do some magic just to pull the downpipe out as there wasn’t enough clearance between the ground and the car to remove it. Lol

    I installed the fabspeed spacer. No codes, but all I have done is start the car to check for leaks. We got snow today, so I couldn’t drive it and I didn’t want wake the neighbors revving it.

    One concern I have is the wires from the secondary cat are pretty close to the engine (due to the spacer)...when I first started the car, I smelt some melting....I think it was just the new pipe, but now I am paranoid and may go in and try to move the spacer further from the engine...

    Running JB4 as well...map 1 for now.

    Should I be worried about this wires location?43509EAF-5BCC-4507-AD5E-1B9328BC3DC8.jpeg
     
    RRKnight likes this.
  13. Thelostrican

    Thelostrican Active Member

    Car(s):
    Supra a90, gtr
    Joined:
    Sep 25, 2019
    Location:
    Puerto rico
    Posts:
    34
    Liked:
    25
    Check you're jb4 install, that all cables are correctly installed, in my raptor, you will get some codes if you install the jb4 incorrectly....just sayin
     
  14. RenierR10

    RenierR10 Well-Known Member

    First Name:
    Alexis
    Car(s):
    MKV Supra
    Joined:
    Aug 28, 2019
    Location:
    New York
    Posts:
    64
    Liked:
    31
    Garage Profiles:
    1
    That spacer looks different than my Fabspeed spacer. When I ordered through Titan they didn’t specify which I would be getting. Maybe the other one would clear the CEL
     
  15. RRKnight

    RRKnight Well-Known Member

    First Name:
    Rocky
    Car(s):
    Lexus NCX200T F Sport
    Joined:
    Feb 28, 2019
    Location:
    Toronto
    Posts:
    266
    Liked:
    180
    Thanks U checked it again and cleared the code last night. Will monitor it and hopefully it doesn't come back again.
     

Share This Page

Loading...